欢迎访问wabc.cc — 源码交易 · 软件定制 · 建站服务一站式平台
全部分类
首页 - 首页 - 其他资源 - 产品分类 - 源码 - php - 如何在CentOS安装和配置PHP加速插件eAccelerator和Zend Opcache
https://yingnet.oss-cn-shenzhen.aliyuncs.com/demo/20191222/123.jpg

如何在CentOS安装和配置PHP加速插件eAccelerator和Zend Opcache

据说PHP开启加速后,速度可以提升3-5倍,于是决定在Centos中安装加速插件eAccelerator和Zend Opcache,后研究得知PHP 5.5已经集成 Zend Opcache,php5.5以后版本编译eAccelerator报错。所以不需要安装配置eAccelerator,直接开始搞Opcache. 大家知道目前PHP的缓存插件一般有三个: APC、 eAccelerator、
价格面议议价成交 · 担保交易 · 支持二次开发
分类:php · 浏览:3 · 更新:2025-12-22

据说PHP开启加速后,速度可以提升3-5倍,于是决定在Centos中安装加速插件eAccelerator和Zend Opcache,后研究得知PHP 5.5已经集成 Zend Opcache,php5.5以后版本编译eAccelerator报错。所以不需要安装配置eAccelerator,直接开始搞Opcache.

大家知道目前PHP的缓存插件一般有三个: APC、 eAccelerator、 XCache,但未来它们可能都会消失,因为PHP 5.5已经集成 Zend Opcache,功能和前三者相似但又有少许不同,缓存速度据说比它们更快(注意:只是据说,我没测试过)。

php5.5以后版本编译eAccelerator报错如下:

eaccelerator.c:66:23: error: php_logos.h: No such file or directory

究其原因是PHP5.5以下版本有php_logos.c,php_logos.h等文件。

如果想在新版本继续用加速,目前知道是的php自带扩展 opcache。

操作如下:_——注意 PHP路径要改成自己的。因为PHP已经自带了,所以直接切换到目录即可。

cd /usr/local/src/php-5.6.0/ext/opcache
/usr/local/webserver/php/bin/phpize
./configure --with-php-config=/usr/local/webserver/php/bin/php-config
make && make install

最好修改/etc/php.ini(路径也要改成自己的)在最后加入

复制代码
[opcache]
zend_extension=/usr/local/webserver/php/lib/php/extensions/no-debug-non-zts-20131226/opcache.so
opcache.memory_consumption=128
opcache.interned_strings_buffer=8
opcache.max_accelerated_files=4000
opcache.revalidate_freq=60
opcache.fast_shutdown=1
opcache.enable_cli=1
复制代码

重启php-fpm:

上一篇:linux系统PHP解密扩展组件ioncube_loaders_lin_x86-64.tar.gz下载
下一篇:Centos中如何同时安装PHP5.6 PHP7.2两个不同版本的PHP

相关源码推荐

联系我们

  • 电话:18566180025
  • 邮箱:www@tma.cn
  • 地址:东莞市科技园
  • 发布需求